Seam Class |
The Seam class represents a seam. A seam is something that connects a main part to other parts along an edge.
Inheritance Hierarchy
SystemObject
Tekla.Structures.ModelObject
Tekla.Structures.ModelModelObject
Tekla.Structures.ModelBaseComponent
Tekla.Structures.ModelSeam
Tekla.Structures.ModelObject
Tekla.Structures.ModelModelObject
Tekla.Structures.ModelBaseComponent
Tekla.Structures.ModelSeam
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The Seam type exposes the following members.
Constructors
Properties
Name | Description | |
---|---|---|
AutoDirectionType |
The auto direction type. Default value is AUTODIR_BASIC.
Value should be AUTODIR_NA to set direction with UpVector property.
Value should be AUTODIR_FROM_ATTRIBUTE_FILE to set direction with seam attribute file.
| |
AutoPosition |
The auto position type. Defines that the seam will internally evaluate the final position more accurately. The input
positions are still needed for reference.
| |
Class |
The class of the seam.
| |
Code |
The code of the seam. The code can be used to classify the seam.
The code can be reported and shown in drawings.
The maximum length of the string is 20 characters.
| |
Identifier |
The identifier of the object.
(Inherited from Object.) | |
IsUpToDate | Gets if the object does not have a modification which is not shared. (Inherited from ModelObject.) | |
ModificationTime | Gets latest time of the object was modified or created. (Inherited from ModelObject.) | |
Name |
The name of the component. The name identifies custom components or plug-ins.
(Inherited from BaseComponent.) | |
Number |
The number of the component. A number greater than zero identifies system components,
for custom components the number is CUSTOM_OBJECT_NUMBER, and for plug-ins the number is PLUGIN_OBJECT_NUMBER.
(Inherited from BaseComponent.) | |
Status |
The read only status of the seam.
The status can be reported and shown in drawings.
The color of the connection symbol in the model indicates the status of the seam.
| |
UpVector |
A vector indicating which direction is considered the up direction for the seam.
|
Methods
Name | Description | |
---|---|---|
CompareTo |
Compares Identifiers of model objects.
(Inherited from ModelObject.) | |
Delete |
Deletes the seam instance with the given ID from the model database.
(Overrides ModelObjectDelete.) | |
Equals |
Check if Identifiers of model objects are same.
(Inherited from ModelObject.) | |
GetAllReportProperties |
Retrieves all properties for the model object in one hashtable.
Type for the returned value must be checked using type casting.
(Inherited from ModelObject.) | |
GetAllUserProperties |
Retrieves all properties for the model object in one hashtable.
Type for the returned value must be checked using type casting.
(Inherited from ModelObject.) | |
GetAttribute(String, Double) |
Retrieves the attribute with the given name.
(Inherited from BaseComponent.) | |
GetAttribute(String, Int32) |
Retrieves the attribute with the given name.
(Inherited from BaseComponent.) | |
GetAttribute(String, String) |
Retrieves the attribute with the given name.
(Inherited from BaseComponent.) | |
GetChildren |
Returns an enumerator of all the children model objects.
(Inherited from ModelObject.) | |
GetCoordinateSystem |
Returns the coordinate system for the given model object.
(Inherited from ModelObject.) | |
GetDoubleReportProperties |
Retrieves multiple double report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) | |
GetDoubleUserProperties |
Retrieves all double properties for the model object.
(Inherited from ModelObject.) | |
GetDynamicStringProperty |
Gets a dynamic string property from the model object.
(Inherited from ModelObject.) | |
GetFatherComponent |
Returns the father component of the model object.
(Inherited from ModelObject.) | |
GetHierarchicObjects |
Returns an enumerator of all the connected hierarchic objects.
(Inherited from ModelObject.) | |
GetInputPolygon |
Returns the input polygon of the seam.
| |
GetIntegerReportProperties |
Retrieves multiple integer report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) | |
GetIntegerUserProperties |
Retrieves all integer properties for the model object.
(Inherited from ModelObject.) | |
GetPhase |
Retrieves the phase of the model object (the phase number, the phase name,
the phase comment and whether the phase is the current one or not).
(Inherited from ModelObject.) | |
GetPrimaryObject |
Returns the primary object.
| |
GetReportProperty(String, Double) |
Retrieves a double property of the report for the model object.
(Inherited from ModelObject.) | |
GetReportProperty(String, Int32) |
Retrieves an integer property of the report for the model object.
(Inherited from ModelObject.) | |
GetReportProperty(String, String) |
Retrieves a string property of the report for the model object.
(Inherited from ModelObject.) | |
GetSecondaryObjects |
Returns an array list containing all the secondary objects.
| |
GetStartAndEndPositions |
Returns the start and end points of the seam.
| |
GetStringReportProperties |
Retrieves multiple string report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) | |
GetStringUserProperties |
Retrieves all string properties for the model object.
(Inherited from ModelObject.) | |
GetUserProperty(String, Double) |
Retrieves a double property for the model object.
(Inherited from ModelObject.) | |
GetUserProperty(String, Int32) |
Retrieves an integer property for the model object.
(Inherited from ModelObject.) | |
GetUserProperty(String, String) |
Retrieves a string property for the model object.
(Inherited from ModelObject.) | |
Insert |
Inserts the seam into the model database. All the attributes must be set.
(Overrides ModelObjectInsert.) | |
LoadAttributesFromFile |
Loads the attributes for the component from the given file. These attributes
will be loaded before all the attributes that have been set with the SetAttribute
methods, so any attributes that are set with SetAttribute will override those
loaded from the given standard file.
(Inherited from BaseComponent.) | |
Modify |
Modifies the existing seam in the model database to match the current one.
(Overrides ModelObjectModify.) | |
Select |
Selects a seam from the model database. The seam ID must be set.
(Overrides ModelObjectSelect.) | |
SetAttribute(String, Double) |
Sets the attribute's value to the given value.
(Inherited from BaseComponent.) | |
SetAttribute(String, Int32) |
Sets the attribute's value to the given value.
(Inherited from BaseComponent.) | |
SetAttribute(String, String) |
Sets the attribute's value to the given value.
(Inherited from BaseComponent.) | |
SetDynamicStringProperty |
Sets a dynamic string property for the model object.
(Inherited from ModelObject.) | |
SetInputPolygon |
Sets the input polygon of the seam.
| |
SetInputPositions |
Sets the start and end point of the seam.
| |
SetLabel |
Sets a label for an object when a new instance is created, this method must be called before Insert.
The label is used in plug-ins for identifying the changed object in modification.
(Inherited from ModelObject.) | |
SetPhase |
Sets the phase of the model object.
(Inherited from ModelObject.) | |
SetPrimaryObject |
Sets the primary object.
| |
SetSecondaryObject |
Sets the secondary object of the seam. Use this
method if you wish to add only one secondary object
to the seam.
| |
SetSecondaryObjects |
Sets the secondary objects.
| |
SetUserProperties |
Sets multiple properties for the model object.
(Inherited from ModelObject.) | |
SetUserProperty(String, Double) |
Sets a double property for the model object.
(Inherited from ModelObject.) | |
SetUserProperty(String, Int32) |
Sets an integer property for the model object.
(Inherited from ModelObject.) | |
SetUserProperty(String, String) |
Sets a string property for the model object.
(Inherited from ModelObject.) |
Examples
using Tekla.Structures.Model; using Tekla.Structures.Geometry3d; using Tekla.Structures; using System; public class Example { public void Example1() { Beam B1 = new Beam(new Point(15000,3000,0), new Point(21000,3000,0)); B1.Profile.ProfileString = "780*380"; B1.Material.MaterialString = "K40-1"; B1.Class = "5"; B1.Position.Plane = Position.PlaneEnum.MIDDLE; B1.Position.Rotation = Position.RotationEnum.TOP; B1.Position.Depth = Position.DepthEnum.BEHIND; Beam B2 = new Beam(new Point(15000,3000,0), new Point(21000,3000,0)); B2.Profile.ProfileString = "780*380"; B2.Material.MaterialString = "K40-1"; B2.Class = "6"; B2.Position.Plane = Position.PlaneEnum.MIDDLE; B2.Position.Rotation = Position.RotationEnum.TOP; B2.Position.Depth = Position.DepthEnum.FRONT; B1.Insert(); B2.Insert(); Seam S = new Seam(); S.Name = "seamdm"; S.Number = -1; S.LoadAttributesFromFile("standard"); S.UpVector = new Vector(0,0,0); S.AutoDirectionType = AutoDirectionTypeEnum.AUTODIR_BASIC; S.AutoPosition = true; S.SetPrimaryObject(B1); S.SetSecondaryObject(B2); S.SetInputPositions(new Point(15000,3000,0), new Point(21000,3000,0)); if(!S.Insert()) Console.WriteLine("Seam Insert failed"); else Console.WriteLine(S.Identifier.ID); } }
See Also