ReportTemplateElement Class |
The ReportTemplateElement class represents a template in the Tekla Structures template library.
Inheritance Hierarchy
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The ReportTemplateElement type exposes the following members.
Constructors
Name | Description | |
---|---|---|
ReportTemplateElement |
Creates a new report template element instance with the default template.
| |
ReportTemplateElement(TemplateInfo) |
Creates a new report template element instance with the given template.
|
Properties
Methods
Name | Description | |
---|---|---|
Clone |
Clones the object.
(Overrides ElementBaseClone.) | |
GetUnformattedString |
Returns the content as a string without formatting.
(Overrides ElementBaseGetUnformattedString.) | |
IsEqual |
Compares the current object with an object of the same type.
(Overrides ElementBaseIsEqual(Object).) |
See Also