PolycurveGeometryBuilderReplace Method (Int32, LineSegment)

Replaces the geometry at a given index

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public PolycurveGeometryBuilder Replace(
	int index,
	LineSegment segment
)

Parameters

index
Type: SystemInt32
Index of the geometry to replace
segment
Type: Tekla.Structures.Geometry3dLineSegment
Geometry to insert in place of the existing one

Return Value

Type: PolycurveGeometryBuilder
The builder itself
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next