DistanceListRemove Method

Removes the specified item.

Namespace:  Tekla.Structures.Datatype
Assembly:  Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
Examples
This example shows how to remove a Distance instance from a DistanceList.
using Tekla.Structures.Datatype;

public class Example
{
       public void Example1()
       {
           Distance[] distances = { new Distance(30.2), new Distance(40, Distance.UnitType.Inch) };
           DistanceList distanceList = new DistanceList(distances);

           // Distances can be removed by value. The first matching distance will be removed.
           bool removed = distanceList.Remove(new Distance(40, Distance.UnitType.Inch));
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next