ReinforcementGroup Class |
The ReinforcementGroup class defines a reinforcement group in the drawing.
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingDatabaseObject
Tekla.Structures.DrawingDrawingObject
Tekla.Structures.DrawingModelObject
Tekla.Structures.DrawingReinforcementBase
Tekla.Structures.DrawingReinforcementGroup
Tekla.Structures.DrawingDatabaseObject
Tekla.Structures.DrawingDrawingObject
Tekla.Structures.DrawingModelObject
Tekla.Structures.DrawingReinforcementBase
Tekla.Structures.DrawingReinforcementGroup
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The ReinforcementGroup type exposes the following members.
Properties
Name | Description | |
---|---|---|
Attributes |
The attributes of the reinforcement.
For more information see ReinforcementBaseReinforcementGroupAttributes.
| |
Hideable |
Accesses the information if this object is hidden or not or if it should be.
(Inherited from ModelObject.) | |
ModelIdentifier |
The database identifier of the model object in the model database.
By using this identifier, it is possible to select the actual object
in the Tekla Structures model.
(Inherited from ModelObject.) | |
QueryReturnValue |
Status information about the latest database operation (select, insert, modify, delete).
(Inherited from DatabaseObject.) | |
ReinforcementCustomPosition |
Defines the location of the reinforcement bar when using ReinforcementVisibility == ReinforcementVisibilityTypes.Customized.
This location is a value between 0.0 and 1.0 and it defines the proportion from the reinforcement's start point.
|
Methods
Name | Description | |
---|---|---|
Delete |
Deletes the drawing reinforcement from the current drawing database.
(Inherited from ReinforcementBase.) | |
GetDoubleUserProperties(DictionaryString, Double) |
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetDoubleUserProperties(ListString, DictionaryString, Double) |
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetDrawing |
Gets the drawing where the drawing object is.
(Inherited from DrawingObject.) | |
GetIntegerUserProperties(DictionaryString, Int32) |
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetIntegerUserProperties(ListString, DictionaryString, Int32) |
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetRelatedObjects |
Gets the related objects of the current object.
(Inherited from DrawingObject.) | |
GetRelatedObjects(Type) |
Gets the related objects of the current object that are of certain types.
(Inherited from DrawingObject.) | |
GetStringUserProperties(DictionaryString, String) |
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetStringUserProperties(ListString, DictionaryString, String) |
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetUserProperty(String, Double) |
Gets a double property from the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
GetUserProperty(String, Int32) |
Gets an integer property from the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
GetUserProperty(String, String) |
Gets a string property from the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
GetView |
Gets the view where the drawing object is.
(Inherited from DrawingObject.) | |
Insert |
Inserts the drawing reinforcement into the current drawing database.
NOT YET IMPLEMENTED.
(Inherited from ReinforcementBase.) | |
IsEqual |
Compares the current object with an object of the same type.
(Overrides DrawingObjectIsEqual(Object).) | |
IsSameDatabaseObject |
Returns true if the current object and the given object are referencing the same database object.
(Inherited from DatabaseObject.) | |
Modify |
Modifies the drawing reinforcement in the current drawing database.
(Inherited from ReinforcementBase.) | |
Select |
Selects the drawing reinforcement from the current drawing database.
(Inherited from ReinforcementBase.) | |
SetUserProperty(String, Double) |
Sets a double property for the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
SetUserProperty(String, Int32) |
Sets an integer property for the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
SetUserProperty(String, String) |
Sets a string property for the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
ToString |
Changes the string presentation of the drawing object.
(Inherited from DrawingObject.) |
See Also