Reinforcement Class |
The Reinforcement class represents a reinforcement in the model. A reinforcement can either be a mesh,
a single rebar, a rebar group or a strand.
Inheritance Hierarchy
SystemObject
Tekla.Structures.ModelObject
Tekla.Structures.ModelModelObject
Tekla.Structures.ModelReinforcement
Tekla.Structures.ModelBaseRebarGroup
Tekla.Structures.ModelRebarMesh
Tekla.Structures.ModelRebarStrand
Tekla.Structures.ModelSingleRebar
Tekla.Structures.ModelObject
Tekla.Structures.ModelModelObject
Tekla.Structures.ModelReinforcement
Tekla.Structures.ModelBaseRebarGroup
Tekla.Structures.ModelRebarMesh
Tekla.Structures.ModelRebarStrand
Tekla.Structures.ModelSingleRebar
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The Reinforcement type exposes the following members.
Properties
Name | Description | |
---|---|---|
Class |
Gets or sets the class of the reinforcement. The class is used to group reinforcements.
| |
EndPointOffsetType |
Gets or sets the type of the end point offset. The options are:
| |
EndPointOffsetValue |
Gets or sets the concrete cover thickness or leg length at the second end of the bar.
| |
Father |
Gets or sets the father object of the reinforcement; the model object instance to operate on.
| |
FromPlaneOffset |
Gets or sets the offset value from the part surface.
| |
Grade |
Gets or sets the steel grade of the reinforcing bar.
The grade indicates the strength of the steel used in reinforcing bars.
It can also indicate other factors, such as the weldability or surface deformations of the bar.
| |
Identifier |
The identifier of the object.
(Inherited from Object.) | |
InputPointDeformingState |
Gets or sets the reinforcement input point deforming state.
| |
IsUpToDate | Gets if the object does not have a modification which is not shared. (Inherited from ModelObject.) | |
ModificationTime | Gets latest time of the object was modified or created. (Inherited from ModelObject.) | |
Name |
Gets or sets the name of the reinforcement.
| |
NumberingSeries |
Gets or sets the numbering series of the reinforcement.
| |
OnPlaneOffsets |
Gets or sets the double offset value for each leg on the same plane as the bar.
| |
RadiusValues |
Gets or sets the radius value(s) of the bends in the bar.
| |
StartPointOffsetType |
Gets or sets the type of the start point offset is either OFFSET_TYPE_LEG_LENGTH or OFFSET_TYPE_COVER_THICKNESS.
| |
StartPointOffsetValue |
Gets or sets the concrete cover thickness or leg length at the first end of the bar.
|
Methods
Name | Description | |
---|---|---|
CompareTo |
Compares Identifiers of model objects.
(Inherited from ModelObject.) | |
Delete |
Deletes the instance from the model database.
(Inherited from ModelObject.) | |
Equals |
Check if Identifiers of model objects are same.
(Inherited from ModelObject.) | |
GetAllReportProperties |
Retrieves all properties for the model object in one hashtable.
Type for the returned value must be checked using type casting.
(Inherited from ModelObject.) | |
GetAllUserProperties |
Retrieves all properties for the model object in one hashtable.
Type for the returned value must be checked using type casting.
(Inherited from ModelObject.) | |
GetAssembly |
Returns the assembly that the reinforcement belongs to.
| |
GetChildren |
Returns an enumerator of all the children model objects.
(Inherited from ModelObject.) | |
GetCoordinateSystem |
Returns the coordinate system for the given model object.
(Inherited from ModelObject.) | |
GetDoubleReportProperties |
Retrieves multiple double report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) | |
GetDoubleUserProperties |
Retrieves all double properties for the model object.
(Inherited from ModelObject.) | |
GetDynamicStringProperty |
Gets a dynamic string property from the model object.
(Inherited from ModelObject.) | |
GetFatherComponent |
Returns the father component of the model object.
(Inherited from ModelObject.) | |
GetFatherPour |
Returns the pour that the rebar is associated to.
| |
GetFatherPourUnit |
Returns the pour unit that the rebar is associated to.
| |
GetHierarchicObjects |
Returns an enumerator of all the connected hierarchic objects.
(Inherited from ModelObject.) | |
GetIntegerReportProperties |
Retrieves multiple integer report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) | |
GetIntegerUserProperties |
Retrieves all integer properties for the model object.
(Inherited from ModelObject.) | |
GetNumberOfRebars |
Returns the number of rebars in the reinforcing group.
| |
GetPhase |
Retrieves the phase of the model object (the phase number, the phase name,
the phase comment and whether the phase is the current one or not).
(Inherited from ModelObject.) | |
GetRebarComplexGeometries(Boolean, Boolean, Boolean) |
Retrieves a list of physical reinforcing bars (of type RebarComplexGeometry).
These objects contain physical curves in the 3D space of each reinforcing bar as shown in model view.
RebarComplexGeometry only differs from RebarGeometry by containing a polycurve rather than a polyline.
| |
GetRebarComplexGeometries(Boolean, Boolean, Boolean, ReinforcementRebarGeometrySimplificationTypeEnum) |
Retrieves a list of physical reinforcing bars (of type RebarComplexGeometry).
These objects contain physical curves in the 3D space of each reinforcing bar as shown in model view.
RebarComplexGeometry only differs from RebarGeometry by containing
a polycurve (of Arc and LineSegment objects) rather than a polyline.
The polycurve only contains arcs if the "simplified" parameter is RATIONALIZED or FABRICATION.
If "simplified" is NONE, any arcs will be returned as a series of line segments.
| |
GetRebarGeometries(Boolean) |
Retrieves a list of physical reinforcing bars (of type RebarGeometry).
These objects contain physical points in the 3D space of each reinforcing bar.
| |
GetRebarGeometries(ReinforcementRebarGeometryOptionEnum) |
Retrieves a list of physical reinforcing bars (of type RebarGeometry).
These objects contain physical points in the 3D space of each reinforcing bar.
| |
GetRebarGeometriesWithoutClashes |
Retrieves a list of physical reinforcing bars (of type RebarGeometry).
These objects contain physical points in the 3D space of each reinforcing bar as shown in model view.
In case rebar polygon clashes with itself, physical points are moved to avoid clashing.
| |
GetReportProperty(String, Double) |
Retrieves a double property of the report for the model object.
(Inherited from ModelObject.) | |
GetReportProperty(String, Int32) |
Retrieves an integer property of the report for the model object.
(Inherited from ModelObject.) | |
GetReportProperty(String, String) |
Retrieves a string property of the report for the model object.
(Inherited from ModelObject.) | |
GetSingleRebar |
Returns a single rebar inside the rebar group located by the given index.
The indexing starts from the start point. The rebar represents a physical reinforcing bar
and contains physical points in the 3D space of the bar.
The method returns null on error, for example if given an erroneous index.
The number of rebars in the group can be requested with GetNumberOfRebars().
| |
GetSingleRebarWithoutClash |
Returns a single rebar inside the rebar group located by the given index.
The indexing starts from the start point. The rebar represents a physical reinforcing bar
and contains physical, non-clashing points in the 3D space of the bar.
The method returns null on error, for example if given an erroneous index.
The number of rebars in the group can be requested with GetNumberOfRebars().
| |
GetSolid |
Method for getting the solid information of the reinforcement.
| |
GetStringReportProperties |
Retrieves multiple string report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) | |
GetStringUserProperties |
Retrieves all string properties for the model object.
(Inherited from ModelObject.) | |
GetUserProperty(String, Double) |
Retrieves a double property for the model object.
(Inherited from ModelObject.) | |
GetUserProperty(String, Int32) |
Retrieves an integer property for the model object.
(Inherited from ModelObject.) | |
GetUserProperty(String, String) |
Retrieves a string property for the model object.
(Inherited from ModelObject.) | |
Insert |
Inserts the model object instance into the model database.
(Inherited from ModelObject.) | |
IsGeometryValid |
Tells whether the geometry of a reinforcement object is valid or not.
| |
Modify |
Modifies the model instance in the model database.
(Inherited from ModelObject.) | |
Select |
Selects the model object instance from the model database.
(Inherited from ModelObject.) | |
SetDynamicStringProperty |
Sets a dynamic string property for the model object.
(Inherited from ModelObject.) | |
SetLabel |
Sets a label for an object when a new instance is created, this method must be called before Insert.
The label is used in plug-ins for identifying the changed object in modification.
(Inherited from ModelObject.) | |
SetPhase |
Sets the phase of the model object.
(Inherited from ModelObject.) | |
SetUserProperties |
Sets multiple properties for the model object.
(Inherited from ModelObject.) | |
SetUserProperty(String, Double) |
Sets a double property for the model object.
(Inherited from ModelObject.) | |
SetUserProperty(String, Int32) |
Sets an integer property for the model object.
(Inherited from ModelObject.) | |
SetUserProperty(String, String) |
Sets a string property for the model object.
(Inherited from ModelObject.) |
See Also