ReinforcementBaseReinforcementSetGroupAttributes Class |
The ReinforcementSetGroupAttributes class is the base attributes class for
ReinforcementSetGroup.
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingReinforcementBaseReinforcementBaseAttributes
Tekla.Structures.DrawingReinforcementBaseReinforcementSetGroupAttributes
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingReinforcementBaseReinforcementBaseAttributes
Tekla.Structures.DrawingReinforcementBaseReinforcementSetGroupAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The ReinforcementBaseReinforcementSetGroupAttributes type exposes the following members.
Constructors
Name | Description | |
---|---|---|
ReinforcementBaseReinforcementSetGroupAttributes |
Initializes a new instance of the ReinforcementBaseReinforcementSetGroupAttributes class.
| |
ReinforcementBaseReinforcementSetGroupAttributes(String) |
Initializes a new instance of the ReinforcementBaseReinforcementSetGroupAttributes class that loads the specified attributes.
|
Properties
Name | Description | |
---|---|---|
CustomPresentation |
Custom presentation GUID to be applied to the object type
(Inherited from ReinforcementBaseReinforcementBaseAttributes.) | |
HiddenLines |
The line type of the hidden lines of the reinforcement.
(Inherited from ReinforcementBaseReinforcementBaseAttributes.) | |
HideLinesHiddenByPart |
Defines whether lines hidden by parts should be hidden or not.
(Inherited from ReinforcementBaseReinforcementBaseAttributes.) | |
HideLinesHiddenByReinforcement |
Defines whether lines hidden by reinforcements should be hidden or not.
(Inherited from ReinforcementBaseReinforcementBaseAttributes.) | |
HookedEndSymbolType |
Gets or sets how the hooked ends of reinforcing bars should look like.
| |
ReinforcementRepresentation |
The representation of reinforcing bars.
(Inherited from ReinforcementBaseReinforcementBaseAttributes.) | |
ReinforcementVisibility |
Gets or sets which bars in the group appear in drawings.
| |
StraightEndSymbolType |
Gets or sets how the straight ends of reinforcing bars should look like.
| |
VisibleLines |
The line type of the visible lines of the reinforcement.
(Inherited from ReinforcementBaseReinforcementBaseAttributes.) |
Methods
Name | Description | |
---|---|---|
IsEqual |
Compares the current object with an object of the same type.
(Overrides ReinforcementBaseReinforcementBaseAttributesIsEqual(Object).) | |
LoadAttributes |
Loads the attributes from the attribute file.
(Inherited from ReinforcementBaseReinforcementBaseAttributes.) |
See Also