![]() | ImageListComboBoxRefreshOptionList Method |
Refreshes the option list content.
Namespace: Tekla.Structures.Dialog.UIControls
Assembly: Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
![](/modules/custom/trimble_html_import/icons/SectionExpanded.png)
![](/modules/custom/trimble_html_import/icons/SectionExpanded.png)
The following example demonstrates how to programmatically add a new item to the combo box:
using System; using System.Drawing; using System.Windows.Forms; using Tekla.Structures.Dialog.UIControls; public class ImageListComboBoxExample { private ImageListComboBox ImageListComboBox; public ImageListComboBoxExample() { ImageListComboBox = new ImageListComboBox(); } void AddNewImage() { ImageListComboBox.ImageList.Images.Add("ImageKey", new Bitmap(@"C:\Image.bmp")); ImageListComboBox.RefreshOptionList(); } }
![](/modules/custom/trimble_html_import/icons/SectionExpanded.png)