ReferenceModelObjectAttribute Class |
The ReferenceModelObjectAttribute class is a base class from where concrete attributes are derived from. The documentation about
different attributes and their function can be found from the vendor specification, for example from the IFC format specification.
Inheritance Hierarchy
Namespace: Tekla.Structures.Model.Collaboration
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The ReferenceModelObjectAttribute type exposes the following members.
Properties
Name | Description | |
---|---|---|
Description |
The description of the product.
| |
Extrusion |
The extrusion vector.
| |
Name |
The name of the product.
| |
ObjectType |
The object type of the product.
| |
Origin |
The origin of the extrusion.
| |
ProfileName |
The name of the profile (often empty).
| |
xDir |
The X-axis direction.
|
See Also
Inheritance Hierarchy
SystemObject
Tekla.Structures.Model.CollaborationReferenceModelObjectAttribute
Tekla.Structures.Model.CollaborationIFC2X3_ParametricObject_CircleHollowProfile
Tekla.Structures.Model.CollaborationIFC2X3_ParametricObject_CircleProfile
Tekla.Structures.Model.CollaborationIFC2X3_ParametricObject_CShapeProfile
Tekla.Structures.Model.CollaborationIFC2X3_ParametricObject_EllipseProfile
Tekla.Structures.Model.CollaborationIFC2X3_ParametricObject_IShapeProfile
Tekla.Structures.Model.CollaborationIFC2X3_ParametricObject_LShapeProfile
Tekla.Structures.Model.CollaborationIFC2X3_ParametricObject_RectangleHollowProfile
Tekla.Structures.Model.CollaborationIFC2X3_ParametricObject_RectangleProfile
Tekla.Structures.Model.CollaborationIFC2X3_ParametricObject_TShapeProfile
Tekla.Structures.Model.CollaborationIFC2X3_ParametricObject_UShapeProfile
Tekla.Structures.Model.CollaborationIFC2X3_ParametricObject_ZShapeProfile
Tekla.Structures.Model.CollaborationParametricObject_CustomProfile
Tekla.Structures.Model.CollaborationParametricObject_ObjectBoundingBox
Tekla.Structures.Model.CollaborationReferenceModelObjectAttribute
Tekla.Structures.Model.CollaborationIFC2X3_ParametricObject_CircleHollowProfile
Tekla.Structures.Model.CollaborationIFC2X3_ParametricObject_CircleProfile
Tekla.Structures.Model.CollaborationIFC2X3_ParametricObject_CShapeProfile
Tekla.Structures.Model.CollaborationIFC2X3_ParametricObject_EllipseProfile
Tekla.Structures.Model.CollaborationIFC2X3_ParametricObject_IShapeProfile
Tekla.Structures.Model.CollaborationIFC2X3_ParametricObject_LShapeProfile
Tekla.Structures.Model.CollaborationIFC2X3_ParametricObject_RectangleHollowProfile
Tekla.Structures.Model.CollaborationIFC2X3_ParametricObject_RectangleProfile
Tekla.Structures.Model.CollaborationIFC2X3_ParametricObject_TShapeProfile
Tekla.Structures.Model.CollaborationIFC2X3_ParametricObject_UShapeProfile
Tekla.Structures.Model.CollaborationIFC2X3_ParametricObject_ZShapeProfile
Tekla.Structures.Model.CollaborationParametricObject_CustomProfile
Tekla.Structures.Model.CollaborationParametricObject_ObjectBoundingBox