RectangleRectangleAttributes Class |
The RectangleAttributes class is the attributes class of the rectangle.
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingGraphicObjectGraphicObjectAttributes
Tekla.Structures.DrawingClosedGraphicObjectClosedGraphicObjectAttributes
Tekla.Structures.DrawingRectangleRectangleAttributes
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingGraphicObjectGraphicObjectAttributes
Tekla.Structures.DrawingClosedGraphicObjectClosedGraphicObjectAttributes
Tekla.Structures.DrawingRectangleRectangleAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The RectangleRectangleAttributes type exposes the following members.
Constructors
Name | Description | |
---|---|---|
RectangleRectangleAttributes |
Creates a new default rectangle attributes instance that loads standard attributes.
| |
RectangleRectangleAttributes(String) |
Creates a new rectangle attributes instance that loads the specified attributes.
|
Properties
Name | Description | |
---|---|---|
BehindModelObjects |
Gets or sets whether the closed graphic object is drawn behind model objects
(Inherited from ClosedGraphicObjectClosedGraphicObjectAttributes.) | |
Bulge |
The bulge value for the rectangle.
| |
Hatch |
The hatch attributes of the closed graphic object (the closed graphic object is hatchable).
(Inherited from ClosedGraphicObjectClosedGraphicObjectAttributes.) | |
Line |
The line attributes of the graphic object. A graphic object always consists of lines.
(Inherited from GraphicObjectGraphicObjectAttributes.) |
Methods
Name | Description | |
---|---|---|
IsEqual |
Compares the current object with an object of the same type.
(Overrides AttributesBaseIsEqual(Object).) | |
LoadAttributes |
Loads the attributes from the attribute file.
(Overrides AttributesBaseLoadAttributes(String).) |
See Also