RebarLengthAdjustmentDataNullable Class |
The RebarLengthAdjustmentDataNullable class defines the length adjustment at the end of a reinforcing bar affected by a RebarEndDetailModifier.
If a length adjustment property is null then that property will not be applied to the RebarSet generated reinforcing bars.
Inheritance Hierarchy
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The RebarLengthAdjustmentDataNullable type exposes the following members.
Constructors
Name | Description | |
---|---|---|
RebarLengthAdjustmentDataNullable |
Initializes a new instance of the RebarLengthAdjustmentDataNullable class.
|
Properties
Name | Description | |
---|---|---|
AdjustmentLength |
Gets or sets the adjustment length.
| |
AdjustmentType |
Gets or sets the adjustment type.
|
See Also