RebarLegSurfaceObject Class |
The RebarLegSurfaceObject class represents a polymesh surface for generating rebar legs in a RebarSet.
Inheritance Hierarchy
SystemObject
Tekla.Structures.ModelObject
Tekla.Structures.ModelModelObject
Tekla.Structures.ModelSurfaceObject
Tekla.Structures.ModelRebarLegSurfaceObject
Tekla.Structures.ModelObject
Tekla.Structures.ModelModelObject
Tekla.Structures.ModelSurfaceObject
Tekla.Structures.ModelRebarLegSurfaceObject
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The RebarLegSurfaceObject type exposes the following members.
Constructors
Name | Description | |
---|---|---|
RebarLegSurfaceObject |
Initializes a new instance of the RebarLegSurfaceObject class.
|
Properties
Name | Description | |
---|---|---|
AdditionalOffset |
Gets or sets the user defined offset of the rebar legs from the leg surface object.
| |
Class |
Gets or sets the class of the surface object.
(Inherited from SurfaceObject.) | |
CreateHoles |
Gets or sets a value indicating whether CreateHoles parameter of the surface object.
(Inherited from SurfaceObject.) | |
Father |
Gets or sets the father object of the surface object. The father can be set only before the Insert(), otherwise exception is thrown.
(Inherited from SurfaceObject.) | |
Identifier |
The identifier of the object.
(Inherited from Object.) | |
IsUpToDate | Gets if the object does not have a modification which is not shared. (Inherited from ModelObject.) | |
LayerNumber |
Gets or sets the layer number of the leg surface object.
| |
ModificationTime | Gets latest time of the object was modified or created. (Inherited from ModelObject.) | |
Name |
Gets or sets the name of the surface object.
(Inherited from SurfaceObject.) | |
Polymesh |
Gets or sets the surface geometry brep.
(Inherited from SurfaceObject.) | |
RebarSet |
Gets or sets the RebarSet to which the leg surface object belongs.
| |
Type |
Gets or sets the type of the surface object.
(Inherited from SurfaceObject.) |
Methods
Name | Description | |
---|---|---|
CompareTo |
Compares Identifiers of model objects.
(Inherited from ModelObject.) | |
Delete |
Deletes the model object from the model database.
(Inherited from SurfaceObject.) | |
Equals |
Check if Identifiers of model objects are same.
(Inherited from ModelObject.) | |
GetAllReportProperties |
Retrieves all properties for the model object in one hashtable.
Type for the returned value must be checked using type casting.
(Inherited from ModelObject.) | |
GetAllUserProperties |
Retrieves all properties for the model object in one hashtable.
Type for the returned value must be checked using type casting.
(Inherited from ModelObject.) | |
GetChildren |
Returns an enumerator of all the children model objects.
(Inherited from ModelObject.) | |
GetCoordinateSystem |
Returns the coordinate system for the given model object.
(Inherited from ModelObject.) | |
GetDoubleReportProperties |
Retrieves multiple double report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) | |
GetDoubleUserProperties |
Retrieves all double properties for the model object.
(Inherited from ModelObject.) | |
GetDynamicStringProperty |
Gets a dynamic string property from the model object.
(Inherited from ModelObject.) | |
GetFatherComponent |
Returns the father component of the model object.
(Inherited from ModelObject.) | |
GetHierarchicObjects |
Returns an enumerator of all the connected hierarchic objects.
(Inherited from ModelObject.) | |
GetIntegerReportProperties |
Retrieves multiple integer report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) | |
GetIntegerUserProperties |
Retrieves all integer properties for the model object.
(Inherited from ModelObject.) | |
GetPhase |
Retrieves the phase of the model object (the phase number, the phase name,
the phase comment and whether the phase is the current one or not).
(Inherited from ModelObject.) | |
GetReportProperty(String, Double) |
Retrieves a double property of the report for the model object.
(Inherited from ModelObject.) | |
GetReportProperty(String, Int32) |
Retrieves an integer property of the report for the model object.
(Inherited from ModelObject.) | |
GetReportProperty(String, String) |
Retrieves a string property of the report for the model object.
(Inherited from ModelObject.) | |
GetStringReportProperties |
Retrieves multiple string report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) | |
GetStringUserProperties |
Retrieves all string properties for the model object.
(Inherited from ModelObject.) | |
GetUserProperty(String, Double) |
Retrieves a double property for the model object.
(Inherited from ModelObject.) | |
GetUserProperty(String, Int32) |
Retrieves an integer property for the model object.
(Inherited from ModelObject.) | |
GetUserProperty(String, String) |
Retrieves a string property for the model object.
(Inherited from ModelObject.) | |
Insert |
Inserts the leg surface object into the model database.
(Overrides SurfaceObjectInsert.) | |
Modify |
Modifies the existing leg surface object in the model database to match the current one.
(Overrides SurfaceObjectModify.) | |
Select |
Selects the leg surface object from the model database. The identifier must be set.
(Overrides SurfaceObjectSelect.) | |
SetDynamicStringProperty |
Sets a dynamic string property for the model object.
(Inherited from ModelObject.) | |
SetLabel |
Sets a label for an object when a new instance is created, this method must be called before Insert.
The label is used in plug-ins for identifying the changed object in modification.
(Inherited from ModelObject.) | |
SetPhase |
Sets the phase of the model object.
(Inherited from ModelObject.) | |
SetUserProperties |
Sets multiple properties for the model object.
(Inherited from ModelObject.) | |
SetUserProperty(String, Double) |
Sets a double property for the model object.
(Inherited from ModelObject.) | |
SetUserProperty(String, Int32) |
Sets an integer property for the model object.
(Inherited from ModelObject.) | |
SetUserProperty(String, String) |
Sets a string property for the model object.
(Inherited from ModelObject.) |
Examples
using Tekla.Structures.Model; using Tekla.Structures.Geometry3d; public class Example { public void Example1(Vector[] vertices, int[][] outerWires, IDictionary<int, int[][]> innerWires) { var beam = new Beam(); // Set Beam properties (code omitted)... beam.Insert(); var rebarSet = new RebarSet(); // Set RebarSet properties (code omitted)... rebarSet.Insert(); var legSurface = new RebarLegSurfaceObject(); legSurface.Polymesh = new FacetedBrep(vertices, outerWires, innerWires); legSurface.Father = beam; legSurface.RebarSet = rebarSet; legSurface.LayerNumber = 1; legSurface.AdditionalOffset = 25.0; legSurface.Insert(); } }
See Also