RebarItem Class |
The RebarItem class contains information from the rebars in the catalog
(rebar_database.inp).
Inheritance Hierarchy
Namespace: Tekla.Structures.Catalogs
Assembly: Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The RebarItem type exposes the following members.
Constructors
Properties
Name | Description | |
---|---|---|
ActualDiameter |
The rebar item's actual diameter.
| |
BendRadius |
The rebar item's bending radius.
| |
Code |
The rebar item's code.
| |
CrankedLength |
Gets or sets the cranked length.
| |
CrankedLengthType |
Gets or sets the cranked length type.
| |
CrankExtraOffset |
Gets or sets the crank extra offset.
| |
CrankStraightLength |
Gets or sets the crank straight length.
| |
CrossSectionArea |
The rebar item's cross section area.
| |
CurveTolerance |
Gets or sets the curve tolerance.
| |
ExtraPointShortening |
Gets or sets the extra point shortening.
| |
Grade |
The rebar item's grade.
| |
HookLength135Degrees |
The rebar item's hook length for 135 degrees.
| |
HookLength180Degrees |
The rebar item's hook length for 180 degrees.
| |
HookLength90Degrees |
The rebar item's hook length for 90 degrees.
| |
HookRadius135Degrees |
The rebar item's hook radius for 135 degrees.
| |
HookRadius180Degrees |
The rebar item's hook radius for 180 degrees.
| |
HookRadius90Degrees |
The rebar item's hook radius for 90 degrees.
| |
LapLength |
Gets or sets the lap length.
| |
MaxRadiusRequiringBending |
Gets or sets the max radius requiring bending.
| |
NominalDiameter |
The rebar item's nominal diameter.
| |
Size |
The rebar item's size.
| |
Usage |
The rebar item's usage.
| |
WeightPerLenght |
The rebar item's weight per lenght.
|
Methods
Name | Description | |
---|---|---|
Delete |
Deletes the rebar item from the rebar database.
| |
Export |
Exports the rebar item in the catlog to given file name.
If path is not given rebar is exported to model folder.
If filename is empty rebar name is used as filename.
| |
Insert |
Inserts the rebar item in the rebar database.
| |
Modify |
Modifies the rebar item in the rebar database based on the given parameters.
| |
Select(String, String) |
Selects the rebar item in the rebar database.
| |
Select(String, Double, Boolean) |
Selects the rebar item in the rebar database.
| |
Select(String, String, Double) |
Selects the rebar item in the rebar database.
| |
Select(String, String, String) |
Selects the rebar item in the rebar database.
| |
Select(String, Double, Double, Boolean) |
Selects the rebar item in the rebar database.
| |
Select(String, Double, String, Boolean) |
Selects the rebar item in the rebar database.
|
Fields
Name | Description | |
---|---|---|
DIAGONAL_DISTANCE_STRING |
The diagonal distance string.
| |
DIAGONAL_RATIO_STRING |
The diagonal ratio string.
| |
HORIZONTAL_DISTANCE_STRING |
The horizontal distance string.
| |
HORIZONTAL_RATIO_STRING |
The horizontal ratio string.
| |
MAIN_USAGE |
The main usage string.
| |
TIE_STIRRUP_USAGE |
The tie/stirrup usage string.
|
See Also