RebarHookDataNullable Class |
The RebarHookDataNullable class defines the hook at the end of a reinforcing bar. Hooks are used for anchoring purposes.
Inheritance Hierarchy
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The RebarHookDataNullable type exposes the following members.
Constructors
Name | Description | |
---|---|---|
RebarHookDataNullable |
Initializes a new instance of the RebarHookDataNullable class.
|
Properties
Name | Description | |
---|---|---|
Angle |
Gets or sets the angle of the hook. The value is between -270 to +270 degrees.
| |
Length |
Gets or sets the length of the straight part of the hook.
| |
Radius |
Gets or sets the bending radius of the hook.
| |
Rotation |
Gets or sets the rotation of the hook.
| |
Shape |
Gets or sets the shape of the hook. The options are:
|
See Also