RebarCrankingNullable Class

The RebarCrankingNullable class represents the cranking of reinforcing bars at a RebarEndDetailModifier.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.ModelRebarCrankingNullable

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
[SerializableAttribute]
public class RebarCrankingNullable

The RebarCrankingNullable type exposes the following members.

Constructors
  NameDescription
Public methodRebarCrankingNullable
Initializes a new instance of the RebarCrankingNullable class.
Top
Properties
  NameDescription
Public propertyCrankedDistance
Gets or sets the cranked distance.
Public propertyCrankedLengthType
Gets or sets the cranked length type.
Public propertyCrankedOffset
Gets or sets the cranked offset.
Public propertyCrankedRatio
Gets or sets the cranked ratio.
Public propertyCrankingType
Gets or sets the cranking type.
Public propertyCrankRotation
Gets or sets the crank rotation.
Public propertyCrankStraightLength
Gets or sets the crank straight length.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next