RadiusDimension Class

The RadiusDimension class defines a radius dimension that displays the radius of the given arc.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
[SerializableAttribute]
public sealed class RadiusDimension : DimensionBase

The RadiusDimension type exposes the following members.

Constructors
  NameDescription
Public methodRadiusDimension(ViewBase, Point, Point, Point, Double)
Creates a new radius dimension instance using three points and the distance.
Public methodRadiusDimension(ViewBase, Point, Point, Point, Double, RadiusDimensionAttributes)
Creates a new radius dimension instance with the attributes, three points and the distance.
Top
Properties
  NameDescription
Public propertyArcPoint1
Gets the first arc point.
Public propertyArcPoint2
Gets the second arc point.
Public propertyArcPoint3
Gets the third arc point.
Public propertyAttributes
The radius dimension attributes.
Public propertyDistance
Gets or sets the distance.
Public propertyHideable
Accesses the information if this object is hidden or not or if it should be.
(Inherited from DimensionBase.)
Public propertyQueryReturnValue
Status information about the latest database operation (select, insert, modify, delete).
(Inherited from DatabaseObject.)
Top
Methods
  NameDescription
Public methodDelete
Deletes the dimension from the database.
(Overrides DatabaseObjectDelete.)
Public methodGetDimensionSet
Radius dimensions don't have dimension sets.
(Overrides DimensionBaseGetDimensionSet.)
Public methodGetDimensionSet(Boolean)
Radius dimensions don't have dimension sets.
(Overrides DimensionBaseGetDimensionSet(Boolean).)
Public methodGetDoubleUserProperties(DictionaryString, Double)
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetDoubleUserProperties(ListString, DictionaryString, Double)
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetDrawing
Gets the drawing where the drawing object is.
(Inherited from DrawingObject.)
Public methodGetIntegerUserProperties(DictionaryString, Int32)
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetIntegerUserProperties(ListString, DictionaryString, Int32)
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetRelatedObjects
Gets the related objects of the current object.
(Inherited from DrawingObject.)
Public methodGetRelatedObjects(Type)
Gets the related objects of the current object that are of certain types.
(Inherited from DrawingObject.)
Public methodGetStringUserProperties(DictionaryString, String)
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetStringUserProperties(ListString, DictionaryString, String)
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetUserProperty(String, Double)
Gets a double property from the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodGetUserProperty(String, Int32)
Gets an integer property from the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodGetUserProperty(String, String)
Gets a string property from the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodGetView
Gets the view where the drawing object is.
(Inherited from DrawingObject.)
Public methodInsert
Inserts the dimension into the database.
(Overrides DatabaseObjectInsert.)
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides DrawingObjectIsEqual(Object).)
Public methodIsSameDatabaseObject
Returns true if the current object and the given object are referencing the same database object.
(Inherited from DatabaseObject.)
Public methodModify
Modifies the existing dimension in the database.
(Overrides DatabaseObjectModify.)
Public methodSelect
Selects the radius dimension from the database.
(Overrides DatabaseObjectSelect.)
Public methodSetUserProperty(String, Double)
Sets a double property for the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodSetUserProperty(String, Int32)
Sets an integer property for the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodSetUserProperty(String, String)
Sets a string property for the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodToString
Changes the string presentation of the drawing object.
(Inherited from DrawingObject.)
Top
Examples
using Tekla.Structures.Drawing;
using Tekla.Structures.Geometry3d;

public class Example
{
       public void Example1()
       {
           DrawingHandler MyDrawingHandler = new DrawingHandler();
           ViewBase _view = MyDrawingHandler.GetActiveDrawing().GetSheet().GetAllViews().Current as ViewBase;

           RadiusDimension basicDimension = new RadiusDimension(_view,
               new Point(-1000, 0, 0),
               new Point(0, 1000, 0),
               new Point(1000, 0, 0),
               200);
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next