RadiusDimension Class

The RadiusDimension class defines a radius dimension that displays the radius of the given arc.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
[SerializableAttribute]
public sealed class RadiusDimension : DimensionBase

The RadiusDimension type exposes the following members.

Constructors
  NameDescription
Public methodRadiusDimension(ViewBase, Point, Point, Point, Double)
Creates a new radius dimension instance using three points and the distance.
Public methodRadiusDimension(ViewBase, Point, Point, Point, Double, RadiusDimensionAttributes)
Creates a new radius dimension instance with the attributes, three points and the distance.
Top
Properties
  NameDescription
Public propertyArcPoint1
Gets the first arc point.
Public propertyArcPoint2
Gets the second arc point.
Public propertyArcPoint3
Gets the third arc point.
Public propertyAttributes
The radius dimension attributes.
Public propertyDistance
Gets or sets the distance.
Top
Methods
  NameDescription
Public methodDelete
Deletes the dimension from the database.
(Overrides DatabaseObjectDelete.)
Public methodGetDimensionSet
Radius dimensions don't have dimension sets.
(Overrides DimensionBaseGetDimensionSet.)
Public methodGetDimensionSet(Boolean)
Radius dimensions don't have dimension sets.
(Overrides DimensionBaseGetDimensionSet(Boolean).)
Public methodInsert
Inserts the dimension into the database.
(Overrides DatabaseObjectInsert.)
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides DrawingObjectIsEqual(Object).)
Public methodModify
Modifies the existing dimension in the database.
(Overrides DatabaseObjectModify.)
Public methodSelect
Selects the radius dimension from the database.
(Overrides DatabaseObjectSelect.)
Top
Examples
using Tekla.Structures.Drawing;
using Tekla.Structures.Geometry3d;

public class Example
{
       public void Example1()
       {
           DrawingHandler MyDrawingHandler = new DrawingHandler();
           ViewBase _view = MyDrawingHandler.GetActiveDrawing().GetSheet().GetAllViews().Current as ViewBase;

           RadiusDimension basicDimension = new RadiusDimension(_view,
               new Point(-1000, 0, 0),
               new Point(0, 1000, 0),
               new Point(1000, 0, 0),
               200);
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next