PropertyElementPropertyElementTypePartMarkPropertyElementTypes Class

The PartMarkPropertyElementTypes class represents the available property element types for part marks.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.DrawingPropertyElementPropertyElementTypePartMarkPropertyElementTypes

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
[SerializableAttribute]
public static class PartMarkPropertyElementTypes

The PropertyElementPropertyElementTypePartMarkPropertyElementTypes type exposes the following members.

Methods
  NameDescription
Public methodStatic memberAssemblyPosition
Returns the assembly position property element type.
Public methodStatic memberCamber
Returns the camber property element type.
Public methodStatic memberCenterToCenterDistance
Returns the center-to-center distance property element type.
Public methodStatic memberClass
Returns the class property element type.
Public methodStatic memberFaceDirection
Returns the face direction property element type.
Public methodStatic memberFinish
Returns the finish property element type.
Public methodStatic memberFittingsNsFs
Returns the fittings (NS/FS) property element type.
Public methodStatic memberGageOfOutstandingLeg
Returns the gage of the outstanding leg property element type.
Public methodStatic memberLength
Returns the length property element type.
Public methodStatic memberMaterial
Returns the material property element type.
Public methodStatic memberName
Returns the name property element type.
Public methodStatic memberPartPosition
Returns the part position property element type.
Public methodStatic memberProfile
Returns the profile property element type.
Public methodStatic memberRotationAngle
Returns the rotation angle property element type.
Public methodStatic memberSize
Returns the size property element type.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next