PropertyElementPropertyElementTypeBoltMarkPropertyElementTypes Class

The BoltMarkPropertyElementTypes class represents the available property element types for bolt marks.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.DrawingPropertyElementPropertyElementTypeBoltMarkPropertyElementTypes

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
[SerializableAttribute]
public static class BoltMarkPropertyElementTypes

The PropertyElementPropertyElementTypeBoltMarkPropertyElementTypes type exposes the following members.

Methods
  NameDescription
Public methodStatic memberAssemblyType
Returns the assembly type property element type.
Public methodStatic memberBoltDiameter
Returns the bolt diameter property element type.
Public methodStatic memberBoltLength
Returns the bolt length property element type.
Public methodStatic memberCenterToCenterDistance
Returns the center-to-center distance property element type.
Public methodStatic memberCountersunk
Returns the countersunk property element type.
Public methodStatic memberFullName
Returns the full name property element type.
Public methodStatic memberGageOfOutstandingLeg
Returns the gage of the outstanding leg property element type.
Public methodStatic memberHoleDepth
Returns the hole depth property element type.
Public methodStatic memberHoleDiameter
Returns the hole diameter property element type.
Public methodStatic memberMaterial
Returns the material property element type.
Public methodStatic memberNumberOfBolts
Returns the number of bolts property element type.
Public methodStatic memberShortName
Returns the short name property element type.
Public methodStatic memberSize
Returns the size property element type.
Public methodStatic memberSlotHeight
Returns the slot height property element type.
Public methodStatic memberSlotLength
Returns the slot length property element type.
Public methodStatic memberSlotLengthX
Returns the slot length in the X direction property element type.
Public methodStatic memberSlotLengthY
Returns the slot length in the Y direction property element type.
Public methodStatic memberStandard
Returns the standard property element type.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next