![]() | PropertyElementPropertyElementTypeBoltMarkPropertyElementTypes Class |
The BoltMarkPropertyElementTypes class represents the available property element types for bolt marks.

Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63

The PropertyElementPropertyElementTypeBoltMarkPropertyElementTypes type exposes the following members.

Name | Description | |
---|---|---|
![]() ![]() | AssemblyType | Returns the assembly type property element type. |
![]() ![]() | BoltDiameter | Returns the bolt diameter property element type. |
![]() ![]() | BoltLength | Returns the bolt length property element type. |
![]() ![]() | CenterToCenterDistance | Returns the center-to-center distance property element type. |
![]() ![]() | Countersunk | Returns the countersunk property element type. |
![]() ![]() | FullName | Returns the full name property element type. |
![]() ![]() | GageOfOutstandingLeg | Returns the gage of the outstanding leg property element type. |
![]() ![]() | HoleDepth | Returns the hole depth property element type. |
![]() ![]() | HoleDiameter | Returns the hole diameter property element type. |
![]() ![]() | Material | Returns the material property element type. |
![]() ![]() | NumberOfBolts | Returns the number of bolts property element type. |
![]() ![]() | ShortName | Returns the short name property element type. |
![]() ![]() | Size | Returns the size property element type. |
![]() ![]() | SlotHeight | Returns the slot height property element type. |
![]() ![]() | SlotLength | Returns the slot length property element type. |
![]() ![]() | SlotLengthX | Returns the slot length in the X direction property element type. |
![]() ![]() | SlotLengthY | Returns the slot length in the Y direction property element type. |
![]() ![]() | Standard | Returns the standard property element type. |