ProjectInfo Class |
The ProjectInfo class provides project information about the currently open Tekla Structures model.
Inheritance Hierarchy
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The ProjectInfo type exposes the following members.
Properties
Name | Description | |
---|---|---|
Address |
The address information of the ProjectInfo.
| |
Builder |
The builder information of the ProjectInfo.
| |
Country |
The address country information of the ProjectInfo.
| |
Description |
The description of the ProjectInfo.
| |
Designer |
The designer information of the ProjectInfo.
| |
EndDate |
The end date information of the ProjectInfo.
| |
GUID |
The GUID field of the ProjectInfo.
| |
Info1 |
The Info 1 field of the ProjectInfo.
| |
Info2 |
The Info 2 field of the ProjectInfo.
| |
Location |
The address location information of the ProjectInfo.
| |
ModelSharingLocalPath | Obsolete.
The local folder for model sharing.
Is null if not defined for the model.
| |
ModelSharingServerPath | Obsolete.
The server path for model sharing.
Is null if not defined for the model.
| |
Name |
The name information of the ProjectInfo.
| |
Object |
The object information of the ProjectInfo.
| |
PostalBox |
The address postal box information of the ProjectInfo.
| |
PostalCode |
The address postal code information of the ProjectInfo.
| |
ProjectNumber |
The project number information of the ProjectInfo.
| |
Region |
The address region information of the ProjectInfo.
| |
StartDate |
The start date information of the ProjectInfo.
| |
Town |
The address town information of the ProjectInfo.
|
Methods
Name | Description | |
---|---|---|
GetBasePointByGuid |
Gets a base point by given guid.
| |
GetBasePointByName |
Gets a base point by given name.
| |
GetBasePoints |
Gets all available base points as a list.
| |
GetCurrentCoordsysBasePoint |
Gets the current base point, if set.
| |
GetDoubleUserProperties |
Retrieves all double properties for the ProjectInfo.
| |
GetDynamicStringProperty |
Gets a dynamic string property for the ProjectInfo.
| |
GetIntegerUserProperties |
Retrieves all integer properties for the ProjectInfo.
| |
GetProjectBasePoint |
Gets the project base point, if any set.
| |
GetStringUserProperties |
Retrieves all string properties for the ProjectInfo.
| |
GetUserProperty(String, Double) |
Retrieves a double property for the ProjectInfo.
| |
GetUserProperty(String, Int32) |
Retrieves an integer property for the ProjectInfo.
| |
GetUserProperty(String, String) |
Retrieves a string property for the ProjectInfo.
| |
Modify |
Modifies the current project information.
| |
SetCurrentCoordsysToBasePoint |
Sets the current base point.
| |
SetDynamicStringProperty |
Sets a dynamic string property for the ProjectInfo.
| |
SetUserProperty(String, Double) |
Sets a double property for the ProjectInfo.
| |
SetUserProperty(String, Int32) |
Sets an integer property for the ProjectInfo.
| |
SetUserProperty(String, String) |
Sets a string property for the ProjectInfo.
|
Examples
The following example gets the project information and shows the value of the Name property
in a message dialog:
using Tekla.Structures.Model; using System.Windows.Forms; public class Example { public void Example1() { Model CurrentModel = new Model(); ProjectInfo ProjectInfo = CurrentModel.GetProjectInfo(); if (CurrentModel.GetConnectionStatus()) { if (ProjectInfo.Name.Length > 0) { MessageBox.Show(ProjectInfo.Name); } } } }
See Also