ProfileProfileString Property |
The profile in human-readable form.
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
Examples
The profile of a beam is set to standard L profile "L400*200*60":
using Tekla.Structures.Model; using Tekla.Structures.Geometry3d; public class Example { public void Example1() { Point point = new Point(5000, 0, 0); Point point2 = new Point(7000, 0, 0); Beam Beam = new Beam(point, point2); string ParametricProfileSeparator = "*"; string ShapeTypeL = "L"; string LshapeProfileDepth = "400"; string LshapeProfileWidth = "200"; string LshapeProfileThickness = "60"; Beam.Profile.ProfileString = ShapeTypeL; Beam.Profile.ProfileString += LshapeProfileDepth; Beam.Profile.ProfileString += ParametricProfileSeparator; Beam.Profile.ProfileString += LshapeProfileWidth; Beam.Profile.ProfileString += ParametricProfileSeparator; Beam.Profile.ProfileString += LshapeProfileThickness; } }
See Also