ProfileSelectionForm Class |
The ProfileSelectionForm class represents a dialog to select profiles
using the profile catalogs.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Tekla.Structures.Dialog.UIControlsProfileSelectionForm
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Tekla.Structures.Dialog.UIControlsProfileSelectionForm
Namespace: Tekla.Structures.Dialog.UIControls
Assembly: Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The ProfileSelectionForm type exposes the following members.
Constructors
Name | Description | |
---|---|---|
ProfileSelectionForm(ListLibraryProfileItem, ListParametricProfileItem) |
Creates a new instance of the ProfileSelectionForm.
| |
ProfileSelectionForm(ListLibraryProfileItem, ListParametricProfileItem, String) |
Creates a new instance of the ProfileSelectionForm selecting the given profile in the tree control.
|
Properties
Name | Description | |
---|---|---|
SelectedProfile |
The selected profile.
|
See Also