ProfileItemSubType Class

The ProfileItemSubType class contains the information of one profile item sub type (id, label, parameter string and bitmap name). A profile item can contain a maximum of 10 profile item sub types.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.CatalogsProfileItemSubType

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
[SerializableAttribute]
public sealed class ProfileItemSubType

The ProfileItemSubType type exposes the following members.

Constructors
  NameDescription
Public methodProfileItemSubType
Initializes a new instance of the ProfileItemSubType class
Top
Properties
  NameDescription
Public propertyBitmapName
Gets a value of the property BitmapName.
Public propertyLabel
Gets a value of the property Label.
Public propertyParameterString
Gets a value of the property ParameterString.
Public propertySubTypeId
Gets a value of the property SubTypeId.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next