ProfileItemProfileItemSubTypeEnum Enumeration |
Defines the different profile item subtypes.
Namespace: Tekla.Structures.Catalogs
Assembly: Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
Members
Member name | Value | Description | |
---|---|---|---|
PROFILE_UNKNOWN_SUBTYPE | 0 | The unknown subtype profile. | |
PROFILE_I_HOT_ROLLED | 1001 | The hot rolled I profile. | |
PROFILE_I_WELDED_SYMMETRICAL | 1002 | The welded symmetrical I profile. | |
PROFILE_I_WELDED_UNSYMMETRICAL | 1003 | The welded unsymmetrical I profile. | |
PROFILE_I_WELDED_SYMMETRICAL2 | 1004 | The welded symmetrical, altering height, I profile. | |
PROFILE_I_WELDED_UNSYMMETRICAL2 | 1005 | The welded unsymmetrical, altering height, I profile. | |
PROFILE_L_HOT_ROLLED | 2001 | The hot rolled L profile. | |
PROFILE_L_COLD_ROLLED | 2002 | The cold rolled L profile. | |
PROFILE_Z_COLD_ROLLED | 3001 | The cold rolled Z profile. | |
PROFILE_U_HOT_ROLLED | 4001 | The hot rolled U profile. | |
PROFILE_U_COLD_ROLLED | 4002 | The cold rolled U profile. | |
PROFILE_PL_DEFAULT | 5001 | The default plate profile. | |
PROFILE_D_CIRCULAR | 6001 | The default circular section profile. | |
PROFILE_D_ELLIPTICAL | 6002 | The elliptical circular section profile. | |
PROFILE_PD_CIRCULAR | 7001 | The default circular hollow section profile. | |
PROFILE_PD_ELLIPTICAL | 7002 | The elliptical circular hollow section profile. | |
PROFILE_PD_CIRCULAR_TAPERED | 7003 | The tapered circular hollow section profile. | |
PROFILE_P_SQUARE | 8001 | The square hollow section profile. | |
PROFILE_P_RECTANGULAR | 8002 | The rectangular hollow section profile. | |
PROFILE_P_ALTERING_HEIGHT | 8003 | The altering height hollow section profile. | |
PROFILE_C_HOT_ROLLED | 9001 | The hot rolled C profile. | |
PROFILE_C_COLD_ROLLED | 9002 | The cold rolled C profile. | |
PROFILE_T_HOT_ROLLED | 10001 | The hot rolled T profile. | |
PROFILE_T_PARAMETRIC | 10002 | The parametric T profile. | |
PROFILE_HK_SYMMETRICAL | 11001 | The symmetrical welded box profile. | |
PROFILE_HK_UNSYMMETRICAL | 11002 | The unsymmetrical welded box profile. | |
PROFILE_HQ_CENTERED | 13001 | The centered HQ profile. | |
PROFILE_HQ_NOT_CENTERED | 13002 | The not centered HQ profile. | |
PROFILE_ZZ_SYMMETRICAL | 15001 | The symmetrical ZZ profile. | |
PROFILE_ZZ_NOT_SYMMETRICAL | 15002 | The unsymmetrical ZZ profile. | |
PROFILE_CC_SYMMETRICAL | 16001 | The symmetrical CC profile. | |
PROFILE_CC_NOT_SYMMETRICAL | 16002 | The unsymmetrical CC profile. | |
PROFILE_CW_SYMMETRICAL | 17001 | The symmetrical CW profile. | |
PROFILE_CW_UNSYMMETRICAL | 17002 | The unsymmetrical CW profile. | |
PROFILE_CU_SYMMETRICAL | 18001 | The symmetrical CU profile. | |
PROFILE_CU_NOT_SYMMETRICAL | 18002 | The unsymmetrical CU profile. | |
PROFILE_EB_SYMMETRICAL | 19001 | The symmetrical EB profile. | |
PROFILE_EB_NOT_SYMMETRICAL | 19002 | The unsymmetrical EB profile. | |
PROFILE_BF_DEFAULT | 20001 | The default BF profile. | |
PROFILE_SPD_CIRCULAR | 21001 | The circular SPD profile. | |
PROFILE_SPD_ELLIPTICAL | 21002 | The elliptical SPD profile. | |
PROFILE_SPD_CIRCULAR_TAPERED | 21003 | The tapered circular SPD profile. | |
PROFILE_EC_SYMMETRICAL | 22001 | The symmetrical EC profile. | |
PROFILE_EC_NOT_SYMMETRICAL | 22002 | The unsymmetrical EC profile. | |
PROFILE_ED_DEFAULT | 23001 | The default ED profile. | |
PROFILE_EE_DEFAULT | 24001 | The default EE profile. | |
PROFILE_EF_DEFAULT | 25001 | The default EF profile. | |
PROFILE_EZ_DEFAULT | 26001 | The default EZ profile. | |
PROFILE_EW_DEFAULT | 27001 | The default EW profile. | |
PROFILE_RCDL_SYMMETRICAL | 102001 | The symmetrical RCDL profile. | |
PROFILE_RCDL_UNSYMMETRICAL | 102002 | The unsymmetrical RCDL profile. | |
PROFILE_RCXX_DEFAULT | 103001 | The RCXX default profile. | |
PROFILE_RCL_DEFAULT | 104001 | The RCL default profile. | |
PROFILE_RCDX_SYMMETRICAL | 105001 | The symmetrical RCDX profile. | |
PROFILE_RCDX_UNSYMMETRICAL | 105002 | The unsymmetrical RCDX profile. | |
PROFILE_RCDX_UNSYMMETRICAL2 | 105003 | The unsymmetrical altered height RCDX profile. | |
PROFILE_RCX_DEFAULT | 106001 | The RCX default profile. |
See Also