ProfileItem Class

The ProfileItem abstract class contains the common information of catalog profiles (parametric and library).
Inheritance Hierarchy

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public abstract class ProfileItem

The ProfileItem type exposes the following members.

Properties
  NameDescription
Public propertyaProfileItemCrossSections
The list of profile item cross-sections.
Public propertyaProfileItemParameters
An array list with the profile item parameters.
Public propertyIsMultiCrossSectionUserParametric
Whether the profile is a parametric user-defined multi cross section profile.
Public propertyIsSketchedUserParametric
Whether the profile is a parametric user-defined sketched profile.
Public propertyNumberOfCrossSections
The number of cross sections in the profile item.
Public propertyParameterString
The profile item parameter string.
Public propertyProfileItemSubType
The profile item subtype.
Public propertyProfileItemType
The profile item type.
Top
Methods
  NameDescription
Public methodCode exampleExport
Exports the profile item in the profile database to given file name. Currently library profiles, sketch profiles and clb profiles are supported. Library profiles are exported to *.lis format. Sketch profiles are exported to *.uel format. Clb profiles are exported to *.clb format. If path is not given profile is exported to model folder. If filename is empty profile name or prefix is used as filename.
Public methodCode exampleGetCrossSection
Returns list of cross section points of inner surfaces from the profile item.
Public methodGetHighAccuracyCrossSection
Get cross section with high accuracy.
Public methodGetProfileItemSubTypes
Selects the profile item and updates the sub types in the profile database.
Public methodIsProfileUserDefined
Whether the profile is a fixed user-defined profile.
Public methodIsProfileUserParametric
Whether the profile is a parametric user-defined profile. If so, the prefix can be asked by type and subtype.
Public methodModifyProfileItemAnalysisParameter
Modify analysis parameter of library profile item. Modify is needed for profile item for updating changes to profile database
Public methodModifyProfileItemParameter
Modify parameter of library profile item. Modify is needed for profile item for updating changes to profile database
Public methodModifyProfileItemUserParameter
Modify user parameter of library profile item. Modify is needed for profile item for updating changes to profile database
Public methodSelect
Selects the profile item in the profile database.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next