ProfileCatalog Class |
The ProfileCatalog class represents a group of controls to select profiles
using the profile catalogs.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Tekla.Structures.Dialog.UIControlsProfileCatalog
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Tekla.Structures.Dialog.UIControlsProfileCatalog
Namespace: Tekla.Structures.Dialog.UIControls
Assembly: Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The ProfileCatalog type exposes the following members.
Constructors
Name | Description | |
---|---|---|
ProfileCatalog |
Initiates a new instance of the control.
| |
ProfileCatalog(String) |
Initiates a new instance of the control selecting the given profile.
|
Properties
Name | Description | |
---|---|---|
ButtonText |
Gets and sets the text of the button control.
| |
SelectedProfile |
The selected profile in the control.
|
Methods
Name | Description | |
---|---|---|
OnValueChanged |
Event handler for passing generic catalog data back to dialog
|
Events
Name | Description | |
---|---|---|
SelectClicked |
The SelectClicked event is raised when the Select button is clicked.
| |
SelectionDone |
The SelectionDone event is raised when the profile selection dialog is closed.
|
See Also