DrawingHandlerPrintDrawings Method (IEnumerableDrawing, DPMPrinterAttributes, String)

Prints the list of drawings using the given printer attributes.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public bool PrintDrawings(
	IEnumerable<Drawing> drawings,
	DPMPrinterAttributes printAttributes,
	string OutputFolder
)

Parameters

drawings
Type: System.Collections.GenericIEnumerableDrawing
The list of drawings to be printed.
printAttributes
Type: Tekla.Structures.DrawingDPMPrinterAttributes
The print attributes for the print job.
OutputFolder
Type: SystemString
The output folder as an absolute path or relateive to the model folder.

Return Value

Type: Boolean
True on success, false if printing fails.
Exceptions
ExceptionCondition
ArgumentExceptionThrown if PDF printing selected, but no file name provided.
ArgumentNullExceptionThrown if drawings or printerAttributes is null.
Remarks
If there is an active drawing visible in the drawing editor and it is a different drawing to the specified drawings, the active drawing will be closed.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next