DrawingHandlerPrintDrawing Method (Drawing, DPMPrinterAttributes)

Prints the drawing using the given printer attributes.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public bool PrintDrawing(
	Drawing drawing,
	DPMPrinterAttributes printAttributes
)

Parameters

drawing
Type: Tekla.Structures.DrawingDrawing
The drawing to be printed.
printAttributes
Type: Tekla.Structures.DrawingDPMPrinterAttributes
The print attributes for the print job.

Return Value

Type: Boolean
True on success, false if printing fails.
Exceptions
ExceptionCondition
ArgumentExceptionThrown if PDF printing selected, but no file name provided.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next