PrintAttributes Class

The PrintAttributes class contains the attributes for controlling the printing.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
[SerializableAttribute]
public sealed class PrintAttributes : GenericAttributesBase

The PrintAttributes type exposes the following members.

Constructors
  NameDescription
Public methodPrintAttributes
Creates a new PrintAttributes instance.
Top
Properties
  NameDescription
Public propertyNumberOfCopies
The number of copies in printing.
Public propertyOrientation
The print orientation type.
Public propertyPrintArea
The print area type.
Public propertyPrinterInstance
The name of the printer instance. Can be fetched from the printer catalog.
Public propertyPrintToMultipleSheet
Whether to print to multiple sheets.
Public propertyScale
The scale factor.
Public propertyScalingType
The scale type.
Top
Methods
  NameDescription
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides GenericAttributesBaseIsEqual(Object).)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next