PrintAttributes Class |
The PrintAttributes class contains the attributes for controlling the printing.
Inheritance Hierarchy
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The PrintAttributes type exposes the following members.
Constructors
Name | Description | |
---|---|---|
PrintAttributes |
Creates a new PrintAttributes instance.
|
Properties
Name | Description | |
---|---|---|
NumberOfCopies |
The number of copies in printing.
| |
Orientation |
The print orientation type.
| |
PrintArea |
The print area type.
| |
PrinterInstance |
The name of the printer instance.
Can be fetched from the printer catalog.
| |
PrintToMultipleSheet |
Whether to print to multiple sheets.
| |
Scale |
The scale factor.
| |
ScalingType |
The scale type.
|
Methods
Name | Description | |
---|---|---|
IsEqual |
Compares the current object with an object of the same type.
(Overrides GenericAttributesBaseIsEqual(Object).) |
See Also