PreferredPlacingTypes Class

The PreferredPlacingTypes class contains all the available preferred placing types. Please note that not all objects accept all types. If you try to use the wrong type it will not be accepted (Insert, Modify will fail).
Inheritance Hierarchy
SystemObject
  Tekla.Structures.DrawingPreferredPlacingTypes

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public static class PreferredPlacingTypes

The PreferredPlacingTypes type exposes the following members.

Methods
  NameDescription
Public methodStatic memberAlongLineOrWithLeaderLineAndParentObjectAlongPartPlacingType
The object is placed using the along line placing as the first option. If there is no room for the first option the fallback option will be used. The fallback option is placing the object with a leader line and rotated to be at the same angle as the connected part.
Public methodStatic memberAlongLineOrWithLeaderLinePlacingType
The object is placed using the along line placing as the first option. If there is no room for the first option the fallback option will be used. The fallback option is placing the object with a leader line.
Public methodStatic memberAlongLinePlacingType
The object is placed using the along line placing.
Public methodStatic memberAlongPartCenteredPlacingType
The object is placed using the along line placing. The line used will be the part's edge in the center of that line.
Public methodStatic memberBaseLinePlacingType
The object is placed using the base line placing.
Public methodStatic memberBaseLineWithArrowAtEndPointPlacingType
The object is placed using the base line placing. The line is drawn and will have an arrow at the end point.
Public methodStatic memberBaseLineWithArrowAtStartPointPlacingType
The object is placed using the base line placing. The line is drawn and will have an arrow at the start point.
Public methodStatic memberInsidePartAlongPartOrWithLeaderLinePlacingType
The object is placed using the base line placing as the first option. If there is no room for the first option the fallback option will be used. The fallback option is placing the object with a leader line. The base line used is in the middle of the part, aligned with the part.
Public methodStatic memberInsidePartAlongPartPlacingType
The object is placed using the base line placing. The base line used is in the middle of the part, aligned with the part.
Public methodStatic memberInsidePartHorizontalOrWithLeaderLinePlacingType
The object is placed using the base line placing as the first option. If there is no room for the first option the fallback option will be used. The fallback option is placing the object with a leader line. The base line used is in the middle of the part, aligned with the part. In addition the object will be rotated to be horizontal in the drawing.
Public methodStatic memberInsidePartHorizontalPlacingType
The object is placed using the base line placing. The base line used is in the middle of the part, aligned with the part. In addition the object will be rotated to be horizontal in the drawing.
Public methodStatic memberLeaderLineAndParentObjectAlongPartPlacingType
The object is placed with a leader line and rotated to be at the same angle as the connected part.
Public methodStatic memberLeaderLinePlacingType
The object is placed with a leader line.
Public methodStatic memberPointPlacingType
The object is placed at one point (the insertion point) without any additional placing options.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next