![]() | PourObjectPourAttributes Class |
The PourAttributes class is the attributes class for the pour.

SystemObject
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingPourObjectPourAttributes
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingPourObjectPourAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63

The PourObjectPourAttributes type exposes the following members.

Name | Description | |
---|---|---|
![]() | PourObjectPourAttributes |
Creates a new default pour attributes instance that loads standard attributes.
|
![]() | PourObjectPourAttributes(String) |
Creates a new pour attributes instance that loads the specified attributes.
|

Name | Description | |
---|---|---|
![]() | DrawChamfers |
True if chamfers are drawn.
|
![]() | DrawHiddenLines |
True if hidden lines are drawn.
|
![]() | DrawOwnHiddenLines |
True if own hidden lines are drawn.
|
![]() | FaceHatch |
The hatch type of the face hatch.
|
![]() | HiddenLines |
The line type of hidden lines.
|
![]() | SectionFaceHatch |
The hatch type of the section face hatch.
|
![]() | VisibleLines |
The line type of visible lines.
|

Name | Description | |
---|---|---|
![]() | IsEqual |
Compares the current object with an object of the same type.
(Overrides AttributesBaseIsEqual(Object).) |
![]() | LoadAttributes |
Loads the attributes from the attribute file.
(Overrides AttributesBaseLoadAttributes(String).) |