Position Class |
The Position class defines how a part is positioned relative to the input.
Inheritance Hierarchy
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The Position type exposes the following members.
Constructors
Properties
Name | Description | |
---|---|---|
Depth |
Indicates the positioning in the depth sense.
| |
DepthOffset |
The offset away from the Depth value.
| |
Plane |
Indicates the positioning in the plane sense.
| |
PlaneOffset |
The offset away from the Plane value.
| |
Rotation |
Indicates the positioning in the rotational sense.
| |
RotationOffset |
The offset away from the Rotation value.
|
Examples
Defining the position of a bolt array instance:
using Tekla.Structures.Model; public class Example { public void Example1() { BoltArray MyBoltArray = new BoltArray(); MyBoltArray.Position.Depth = Position.DepthEnum.MIDDLE; MyBoltArray.Position.DepthOffset = 3; MyBoltArray.Position.Plane = Position.PlaneEnum.MIDDLE; MyBoltArray.Position.PlaneOffset = 1; MyBoltArray.Position.Rotation = Position.RotationEnum.FRONT; MyBoltArray.Position.RotationOffset = 2; } }
See Also