PolygonNode Class |
The PolygonNode class represents flat geometry tree node.
Inheritance Hierarchy
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The PolygonNode type exposes the following members.
Constructors
Name | Description | |
---|---|---|
PolygonNode |
Initializes a new instance of the PolygonNode class.
|
Properties
Name | Description | |
---|---|---|
Contour |
Gets or sets the contour points of flat geometry.
| |
IsAutomatic |
Gets a value indicating whether this geometry node was automatically generated (returns false if it was originally a user-defined part)
|
Methods
Name | Description | |
---|---|---|
AcceptVisitor |
Entry method for the visitor pattern
| |
Clone |
Creates a new object that is a copy of the current instance.
|
See Also