PolyLine Class |
The PolyLine class represents a line that consists of one or more line segments.
To create a polyline, you have to give a list of the points that will form the polyline.
The first point in the list will be connected with the second point in the list,
the second point in the list will be connected with the third point in the list, etc.
Inheritance Hierarchy
Namespace: Tekla.Structures.Geometry3d
Assembly: Tekla.Structures (in Tekla.Structures.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The PolyLine type exposes the following members.
Constructors
Properties
Methods
Name | Description | |
---|---|---|
Equals |
Returns true if the objects are equal.
(Overrides ObjectEquals(Object).) | |
GetHashCode |
Returns a hash code for a polyline.
Notice, in extremely rare cases, you might not get the same
hash code for two polylines even though they are considered equal! This
should, however, happen only in extremely rare cases!
(Overrides ObjectGetHashCode.) | |
Length |
Returns the length of a polyline.
|
Operators
Name | Description | |
---|---|---|
Equality |
Checks the equality of two polylines.
| |
Inequality |
Checks the inequality of two polylines.
|
See Also