PluginWindowBase Class

The PluginWindowBase class is the base class for plug-in WPF dialogs. The class extends the WindowBase class by adding communications with Tekla Structures.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Dialog
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public class PluginWindowBase : WindowBase

The PluginWindowBase type exposes the following members.

Constructors
  NameDescription
Public methodPluginWindowBase
Runs the WindowBase constructor and loads the default .NET localization file (DotNetDialogStrings.ail). Datastorage is built based on given viewmodel object
Top
Properties
  NameDescription
Public propertyLocalization
The localization instance for the dialog. Each dialog has its own localization instance that has read the localization files needed for that dialog.
(Inherited from WindowBase.)
Public propertyLocExtension
The localization instance for the dialog. Each dialog has its own localization instance that has read the localization files needed for that dialog.
(Inherited from WindowBase.)
Public propertyShowInTaskbar
Hides (shadows) the ShowInTaskbar property by setting the property to false.
Public propertyUseDefaultStyle
Use default style in all the window controls or not. If the property is not set in the window constructor the default value (true) is used.
(Inherited from WindowBase.)
Top
Methods
  NameDescription
Public methodApplyValues
Loads the dialog values from a file and performs Apply on the loaded values. To match the files to a certain dialog, the file suffix is set as the dialog type's name.
(Inherited from WindowBase.)
Public methodGet
Gets the dialog values from the part that is currently selected in Tekla Structures.
Public methodGetConnectionStatus
Returns true if a proper connection to the Tekla Structures process has been established. Currently, there's no way to re-establish the connection.
(Inherited from WindowBase.)
Public methodInitializeWindow
Prepares the data storage for the dialog and scans through the fields.
(Inherited from WindowBase.)
Public methodLoadValues
Loads the dialog values from a file. To match the files to a certain dialog, the file suffix is set as the dialog type's name.
(Inherited from WindowBase.)
Public methodModifyValues
Loads the dialog values from a file and performs Modify on the loaded values. To match the files to a certain dialog, the file suffix is set as the dialog type's name.
(Inherited from WindowBase.)
Public methodReloadWindow
Reloads the dialog values.
Public methodSaveValues
Serializes the dialog values to an xml file.
(Inherited from WindowBase.)
Public methodShowWindow
Displays the window.
(Inherited from WindowBase.)
Public methodUpdateDataStorageFromViewModel
DO NOT USE! For internal usage only!
(Inherited from WindowBase.)
Top
Events
  NameDescription
Public eventAttributesLoadedFromModel
The AttributesLoadedFromModel event is triggered just after the attributes have been loaded from the model into the dialog.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next