PluginWindowBase Class

The PluginWindowBase class is the base class for plug-in WPF dialogs. The class extends the WindowBase class by adding communications with Tekla Structures.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Dialog
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public class PluginWindowBase : WindowBase

The PluginWindowBase type exposes the following members.

Constructors
  NameDescription
Public methodPluginWindowBase
Runs the WindowBase constructor and loads the default .NET localization file (DotNetDialogStrings.ail). Datastorage is built based on given viewmodel object
Top
Properties
  NameDescription
Public propertyShowInTaskbar
Hides (shadows) the ShowInTaskbar property by setting the property to false.
Top
Methods
  NameDescription
Public methodGet
Gets the dialog values from the part that is currently selected in Tekla Structures.
Public methodReloadWindow
Reloads the dialog values.
Top
Events
  NameDescription
Public eventAttributesLoadedFromModel
The AttributesLoadedFromModel event is triggered just after the attributes have been loaded from the model into the dialog.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next