![]() | PluginSymbolVisiblityAttribute Class |
The PluginSymbolVisiblityAttribute class is used for defining the symbol visibility for model plug-ins.
The attribute is initialized from the custom attribute [PluginSymbolVisiblity(PluginBase.SymbolVisibility Type)] in the plug-in source.
If attribute is not defined or attribute has value PluginBase.SymbolVisibility.DRAW_SYMBOL plug-in symbol is drawn normally.

Namespace: Tekla.Structures.Plugins
Assembly: Tekla.Structures.Plugins (in Tekla.Structures.Plugins.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63

The PluginSymbolVisiblityAttribute type exposes the following members.

Name | Description | |
---|---|---|
![]() | PluginSymbolVisiblityAttribute(Int32) |
The custom attribute used to define coordinate system of the plug-in.
This is not to be used by itself.
|
![]() | PluginSymbolVisiblityAttribute(PluginBaseSymbolVisibility) |
The custom attribute used to define coordinate system of the plug-in.
This is not to be used by itself.
|