PluginPickerInput Class |
The PluginPickerInput class represents a predefined set of picker inputs that can be provided
to a plug-in object. It replaces the interactive selection of points and/or objects by the user
when the plug-in is inserted into a drawing through the API.
Inheritance Hierarchy
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The PluginPickerInput type exposes the following members.
Constructors
Name | Description | |
---|---|---|
PluginPickerInput |
Initializes a new instance of the PluginPickerInput class with an empty list of picker inputs.
| |
PluginPickerInput(ListPickerInput) |
Initializes a new instance of the PluginPickerInput class which contains a predefined sequence
of inputs.
|
Methods
Name | Description | |
---|---|---|
Add |
Appends a picker input to the plug-in input.
| |
AddRange |
Appends several picker inputs to the picker input sequence.
|
See Also