PluginCoordinateSystemAttribute Class |
The PluginCoordinateSystemAttribute class is used for defining the coordinate system type for model plug-ins which are using points as an input.
The attribute is initialized from the custom attribute [PluginCoordinateSystem(PluginBase.CoordinateSystemType Type)] in the plug-in source.
If attribute is not defined or attribute has value PluginBase.CoordinateSystemType.FROM_FIRST_POINT_AND_GLOBAL coordinate system is calculated as earlier.
The attribute is used if the first Inputdefinition object contains at least two points (defined by two points, line, face or polygon).
Inheritance Hierarchy
Namespace: Tekla.Structures.Plugins
Assembly: Tekla.Structures.Plugins (in Tekla.Structures.Plugins.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The PluginCoordinateSystemAttribute type exposes the following members.
Constructors
Name | Description | |
---|---|---|
PluginCoordinateSystemAttribute(Int32) |
The custom attribute used to define coordinate system of the plug-in.
This is not to be used by itself.
| |
PluginCoordinateSystemAttribute(PluginBaseCoordinateSystemType) |
The custom attribute used to define coordinate system of the plug-in.
This is not to be used by itself.
|
Properties
See Also