PluginBaseInputDefinitionInputTypeEnum Enumeration

The possible input types for a plug-in.

Namespace:  Tekla.Structures.Plugins
Assembly:  Tekla.Structures.Plugins (in Tekla.Structures.Plugins.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public enum InputTypeEnum
Members
  Member nameValueDescription
INPUT_ONE_POINT1 The input is one point (x,y,z).
INPUT_TWO_POINTS2 The input is two points.
INPUT_POLYGON3 The input is multiple points.
INPUT_ONE_OBJECT4 The input is one ID of any type.
INPUT_N_OBJECTS5 The input is N IDs of any type.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next