IntersectionPlaneToPlane Method

Returns a new line which is an intersection of the given two planes or null if the planes are parallel.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public static Line PlaneToPlane(
	GeometricPlane plane1,
	GeometricPlane plane2
)

Parameters

plane1
Type: Tekla.Structures.Geometry3dGeometricPlane
The first plane to be used.
plane2
Type: Tekla.Structures.Geometry3dGeometricPlane
The second plane to be used.

Return Value

Type: Line
The intersection line or null if no intersection was found.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next