PlacingQuarterAttributes Class

The PlacingQuarterAttributes class contains the basic attributes for placing quarters.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
[SerializableAttribute]
public sealed class PlacingQuarterAttributes : GenericAttributesBase, 
	ICloneable

The PlacingQuarterAttributes type exposes the following members.

Constructors
  NameDescription
Public methodPlacingQuarterAttributes
Creates a new placing quarter attributes instance. The default parameters are: TopLeft = true, TopRight = true, BottomLeft = true, BottomRight = true.
Public methodPlacingQuarterAttributes(Boolean, Boolean, Boolean, Boolean)
Creates a new placing quarter attributes instance with the given parameters.
Top
Properties
  NameDescription
Public propertyBottomLeft
Defines whether the object can search for a suitable location in the bottom left direction.
Public propertyBottomRight
Defines whether the object can search for a suitable location in the bottom right direction.
Public propertyTopLeft
Defines whether the object can search for a suitable location in the top left direction.
Public propertyTopRight
Defines whether the object can search for a suitable location in the top right direction.
Top
Methods
  NameDescription
Public methodClone
Creates a new object that is a copy of the current instance.
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides GenericAttributesBaseIsEqual(Object).)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next