PlacingDirectionAttributes Class |
The PlacingDirectionAttributes class contains the basic attributes for placing directions.
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingGenericAttributesBase
Tekla.Structures.DrawingPlacingDirectionAttributes
Tekla.Structures.DrawingGenericAttributesBase
Tekla.Structures.DrawingPlacingDirectionAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The PlacingDirectionAttributes type exposes the following members.
Constructors
Name | Description | |
---|---|---|
PlacingDirectionAttributes |
Creates a new placing direction attributes instance. The positive and negative
directions are set to false by default.
| |
PlacingDirectionAttributes(Boolean, Boolean) |
Creates a new placing direction attributes instance.
|
Properties
Name | Description | |
---|---|---|
Negative |
The negative direction of placing.
| |
Positive |
The positive direction of placing.
|
Methods
Name | Description | |
---|---|---|
IsEqual |
Compares the current object with an object of the same type.
(Overrides GenericAttributesBaseIsEqual(Object).) |
See Also