PickerInputThreePoints Constructor |
Creates a new PickerInputThreePoints instance with one point selected in a view.
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public PickerInputThreePoints( ViewBase pickedView, Point firstPickedPoint, Point secondPickedPoint, Point thirdPickedPoint )
Parameters
- pickedView
- Type: Tekla.Structures.DrawingViewBase
The view in which the pick occurred. - firstPickedPoint
- Type: Tekla.Structures.Geometry3dPoint
The first picked point in the view coordinates. - secondPickedPoint
- Type: Tekla.Structures.Geometry3dPoint
The second picked point in the view coordinates. - thirdPickedPoint
- Type: Tekla.Structures.Geometry3dPoint
The third picked point in the view coordinates.
See Also