PickerInputPoint Class |
The PickerInputPoint class represents a pick of one point in a view.
Used for values asked by UI.Picker.PickPoint(string Prompt, out Point PickedPoint, out ViewBase PickedView).
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingPickerInput
Tekla.Structures.DrawingPickerInputWithinAView
Tekla.Structures.DrawingPickerInputPointsWithinAView
Tekla.Structures.DrawingPickerInputPoint
Tekla.Structures.DrawingPickerInput
Tekla.Structures.DrawingPickerInputWithinAView
Tekla.Structures.DrawingPickerInputPointsWithinAView
Tekla.Structures.DrawingPickerInputPoint
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The PickerInputPoint type exposes the following members.
Constructors
Name | Description | |
---|---|---|
PickerInputPoint |
Creates a new PickerInputPoint instance with one point selected in a view.
|
Properties
Name | Description | |
---|---|---|
PickedPoint |
The picked point in the view coordinates.
| |
PickedView |
The view within which the pick occurred.
(Inherited from PickerInputWithinAView.) |
Methods
Name | Description | |
---|---|---|
IsEqual |
Compares the current object with an object of the same type.
(Overrides PickerInputPointsWithinAViewIsEqual(Object).) |
See Also