PickerPickTwoPoints Method |
Requests a pick of two points from the user.
Namespace: Tekla.Structures.Drawing.UI
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public void PickTwoPoints( string firstPrompt, string secondPrompt, out Point firstPickedPoint, out Point secondPickedPoint, out ViewBase pickedView )
Parameters
- firstPrompt
- Type: SystemString
The prompt shown in the status bar before the first pick. See the class remarks for more information about prompts. - secondPrompt
- Type: SystemString
The prompt shown in the status bar before the second pick. See the class remarks for more information about prompts. - firstPickedPoint
- Type: Tekla.Structures.Geometry3dPoint
The first picked point in the view coordinates. - secondPickedPoint
- Type: Tekla.Structures.Geometry3dPoint
The second picked point in the view coordinates. - pickedView
- Type: Tekla.Structures.DrawingViewBase
The view in which the pick occurred.
Exceptions
Exception | Condition |
---|---|
InvalidPluginPickerInputException | Thrown when the picker is being used through a plug-in which has invalid PluginPickerInputs defined. |
PickerInterruptedException | Thrown when the user interrupts the picker before anything has been picked. |
See Also