![]() | PickerPickPoints Method (Int32, StringList, PointList, ViewBase) |
Requests N picks of points from the user.
Namespace: Tekla.Structures.Drawing.UI
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63

public void PickPoints( int numberOfPicks, StringList prompts, out PointList pickedPoints, out ViewBase pickedView )
Parameters
- numberOfPicks
- Type: SystemInt32
The number of requested picks. - prompts
- Type: Tekla.Structures.DrawingStringList
The prompts shown in the status bar before the picks. See the class remarks for more information about prompts. - pickedPoints
- Type: Tekla.Structures.DrawingPointList
The picked points in the view coordinates. - pickedView
- Type: Tekla.Structures.DrawingViewBase
The view in which the pick occurred.

Exception | Condition |
---|---|
InvalidPluginPickerInputException | Thrown when the picker is being used through a plug-in which has invalid PluginPickerInputs defined. |
PickerInterruptedException | Thrown when the user interrupts the picker before anything has been picked. |