PickerPickPoints Method (Int32, StringList) |
Requests N picks of points from the user.
Returns the picked points in the view coordinates and the view in which the pick occurred.
Namespace: Tekla.Structures.Drawing.UI
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
Parameters
- numberOfPicks
- Type: SystemInt32
The number of requested picks. - prompts
- Type: Tekla.Structures.DrawingStringList
The prompts shown in the status bar before the picks. See the class remarks for more information about prompts.
Return Value
Type: TuplePointList, ViewBaseExceptions
Exception | Condition |
---|---|
InvalidPluginPickerInputException | Thrown when the picker is being used through a plug-in which has invalid PluginPickerInputs defined. |
PickerInterruptedException | Thrown when the user interrupts the picker before anything has been picked. |
See Also