AnalysisObjectPickerPickObjects Method

Prompts the user to pick objects from the model with the given prompt.

Namespace:  Tekla.Structures.Analysis.UI
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public List<AnalysisObject> PickObjects(
	string analysisModelName,
	AnalysisObjectPickerPickObjectType type,
	string prompt
)

Parameters

analysisModelName
Type: SystemString
The analysis model name.
type
Type: Tekla.Structures.Analysis.UIAnalysisObjectPickerPickObjectType
The type of objects to pick.
prompt
Type: SystemString
The string to display as user guidance.

Return Value

Type: ListAnalysisObject
An enumerator of analysis object instances.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next