PickerPickObject Method (String, DrawingObject, ViewBase, Point) |
Requests the user to pick one object. Returns the picked point in addition to the picked object.
Namespace: Tekla.Structures.Drawing.UI
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public void PickObject( string prompt, out DrawingObject pickedObject, out ViewBase pickedView, out Point pickedPoint )
Parameters
- prompt
- Type: SystemString
The prompt shown in the status bar before the picks. See the class remarks for more information about prompts. - pickedObject
- Type: Tekla.Structures.DrawingDrawingObject
The picked drawing object. - pickedView
- Type: Tekla.Structures.DrawingViewBase
The view in which the pick occurred. - pickedPoint
- Type: Tekla.Structures.Geometry3dPoint
The picked point in the view coordinates.
Exceptions
Exception | Condition |
---|---|
InvalidPluginPickerInputException | Thrown when the picker is being used through a plug-in which has invalid PluginPickerInputs defined. |
PickerInterruptedException | Thrown when the user interrupts the picker before anything has been picked. |
See Also